Применение

Вы можете поздравлять всех пользователей с началом рабочего дня или с завершением тяжелой рабочей недели. Ушли в отпус? Заведите программу так, чтобы все знали, что Вы где-то здесь (на работе), пусть думают, какой Вы хороший работник: из 24-х дней отпуска Вы отдыхали только по выходным. Это Вам зачтется.

Заведите программу так, что бы она с 17.00 отправляла сообщения с напоминаниями "Не забудьте выключить ПК", а в 23.00 "Вы не выключили ПК, подойдите к администратору сети с объяснением".

Можете завести в программе все дни рождения Ваших собратьев по локалке, поверьте, им будет приятно получать ненавязчивые поздравления через каждые пять минут в течении 3 дней до начала торжества (можете сразу готовить подарок, без Вас не обойтись). Конечно приятно получать поздравления, а еще приятней получать напоминания о том, что у Вашего друга "День варенья!". Сообщите всем, что, например, у Васи Пупкина сегодня именины, но так, чтобы об этом не знал сам Вася. Он просто будет рад тому, что все помнят, когда ему становится на год больше, а еще больше он задумается сколько же уйдет на торжество. Ведь не пригласить того кто тебя поздравил, это же плохо. После такой Вашей практики напоминаний дня именин и подсчета домашнего бюджета после таких праздников, люди не вольно начнут задумываться как же Вас "УГОВОРИТЬ" больше не обращать внимание на их праздники.

Отблагодарите админа локалки за то, что он такой хороший человек, что он много знает и, вообще, эрудированный профессионал в своем деле. И ему тоже станет радостно за то, что его любят люди, которых он обычно называет по доброму юзерами. Возможно, в его глазах Вы станете не только юзером, но и просто человеком с именем, фамилией, кличкой и т.д.

Все зависит от Вашей фантазии. Я надеюсь она не подкачает и Вы найдете достойное применение. Главное, сделайте все правильно. Пишите мне о том как Вы применили программу.

www.CrazyNetSend.narod.ru

Васильев Александр 2004 г.

WebMoney Banner Network Square (100x100)
WMBN Square

WebMoney Banner Network Square (100x100)
WMBN Square


Что такое CNS?

CNS - это программа, предназначенная для автоматического вывода сообщений на локальном ПК и рассылки сообщений по локальной сети. Главная задача программы CNS – автоматическая рассылка сообщений по локальной сети, подробно о способах применения можно будет прочитать ниже.

Основными преимуществами программы CNS являются:

- Планировщик рассылки сообщений
- Интеграция в ОС
- Автоматическое сохранение настроек
- Не требуется инсталляция
- Автозагрузка
- Сохранение базы заданий в файл

Применение программы CNS:

- Напоминания
- Оповещении

www.CrazyNetSend.narod.ru


Техническая характеристика

Программа CNS работает под управлением операционных систем семейства NT, это Win2k/XP/NT. Необходимое условие для работы программы - Служба сообщений. Эта служба посылает и получает сообщения, переданные администраторами или службой оповещений.


Настройки

В программе имеется несколько основных настроек доступные для редактирования пользователям:

- Ярлык на рабочий стол (ShotCut in DeskTop) | Размещение ярлыка программы на рабочий стол, для всех пользователей работающих на данном ПК.
- Ярлык в меню Пуск (ShotCut in Menu Start) | Размещение ярлыка программы в главное меню Пуск, для всех пользователей работающих на данном ПК.
- Автозапуск программы (Auto run programm) | Размещение ярлыка программы в автозагрузку, для всех пользователей работающих на данном ПК. Программа автоматически загружается при загрузке операционной системы.
- Прятать программу при автостарте (Hide programm under auto start) | Если программа автоматически запускается при загрузке операционной системы, то она автоматически сворачивается в Процессы.
- Язык (Language) | Выбор языка интерфейса. Имеется два возможных варианта - Русский и Английский.

Вызвать окно для редактирования настроек - Редактировать->Настройки (Edit->Options) или по нажатию кнопки Настройки (Options) на панели инструментов.

Все изменения в окне Options автоматически сохраняются по нажатию кнопки Оk. Все остальные настройки программы сохраняются автоматически при выходе из программы в файле seting.ini:

Расположение главного окна программы | Координаты расположений окна перед последним закрытием программы.
Имя последней открытой базы заданий | Окно отчета о выполненных заданиях, которое можно вызвать Файл->Окно отчета (File->Report window). Убрать окно отчета можно щелкнуть правой кнопкой в окно и в выпадающем меню выбрать Окно отчета (Report window).
Отображение окна отчета о выполненных задания | Окно отчета о выполненных заданиях, которое можно вызвать Файл->Окно отчета (File->Report window). Убрать окно отчета можно щелкнуть правой кнопкой в окно и в выпадающем меню выбрать Окно отчета (Report window).

Файл с настройками seting.ini можно удалить или очистить, тогда он будет создан вновь но с новыми пустыми значениями. При задании новых настроек они автоматически будут записаны в новый созданный файл.


Панель инструментов

Вид | Название | Описание
 | Открыть файл (Open Tasks) | Открыть файл с сохранеными сообщениями. Файл имеет расширение CNS. При следующем запуске программы будет автоматически открыт.
 | Открыть задания (Save Tasks) | Сохранить файл с сохранеными сообщениями. Файл имеет расширение CNS. При следующем запуске программы будет автоматически открыт.
 | Новое задание (New task) | Создание нового задания.
 | Удалить задание (Delete task) | Удаление задания.
 | Копировать (Copy task) | Копирование задания в буфер обмена.
 | Вставить (Paste task) | Вставить задания из буфера обмена.
 | Запустить задания (Run task) | Запуск программы на исполнение заданий.
 | Настройки (Options) | Настройки программы. Вызывается окно "Options". В котором можно отредактировать настройки программы.
 | О программе (About) | Вызывается окно "О программе".
 | Выход (Exit) | Выход из программы.


Планировщик рассылки сообщений

Планировщик задания состоит из нескольких окон ввода, которые описанны в нижеприведенной таблице.

Название окна ввода | Описание
Имя (Name Task) | Имя задания. По умолчанию "No name" и порядковый номер.
Дата старта (Date start) | Дата старта задания. Указанная дата входит в промежуток.
Дата остановки (Date stop) | Дата остановки задания. Указанная дата входит в промежуток.
Время старта (Time start) | Время старта. Указанное время входит в промежуток.
Время остановки (Time stop) | Время остановки. Указанное время входит в промежуток.
Интервал (Interval) | Интервал между сообщениями. Один интервал = 0.1 секунде.
Количество (In start) | Сколько раз отправлять сообщение. Если количество указанно нулю, сообщения будут отправляться бесконечное число раз, пока подходят другие условия.
Месяц (Month) | В какой месяц года запускать задание.
День месяца (Day of month) | В какой день месяца запускать задание.
Неделя (Week day) | В какой день недели запускать задание.
Компьютер (Computer) | На какой компьютер отправлять сообщение. В выпадающем списке автоматически отображаются компьютеры сети. Если локальная сеть очень большая, то открытие списка может затянутся. Если указать "All" то сообщения будут отправлены на все ПК.
Отпр. остальным (Send not chosen) | Если установлена галочка, то сообщения будут отправлены на все ПК, кроме указанного в окне ввода "Компьютер".
Сообщение (Message) | Текст сообщения.

Если над окном ввода параметра высвечивается Нажмите ESC (Please press ESC), то при нажатии на кнопку ESC окно будет заблокировано и не будет использоваться в условиях отправки сообщения.


Окно отчета

Окно отчета - это окно, в которое регистируется отчет о выполнеых заданиях и отправленных сообщениях, которое распологается в нижней части главного окна. Окно отчета можно вызвать или убрать Файл->Окно отчета (File->Report window). Убрать окно отчета можно щелкнуть правой кнопкой в окно и в выпадающем меню выбрать Окно отчета (Report window). В выпадающем меню можно выбрать пункт Очистить (Clear), что приведет к очистке окна отчета от данных. Данные окна отчета можно сохранить Сохранить отчет (Save report), данные будут сохранены в текстовый файл.


Что такое сайт и зачем он нужен?

Одназначно на этот вопрос трудно ответит, что бы раскрыть все стороны этого вопроса. Начнем с самого простого. Сайт - это набор веб страничек, которые несут в себе информацию. Информация может быть как текстовая так и графическая, а так же в виде определенных файлов, которые можно загрузить на компьютер. Сайт расположен в интернете и доступен для просмотра другим пользователям сети. Содержание сайтов в интернете различно, сколько мне в голову не приходило новых идей, как я думал, заходя в поисковик я обнаруживал множество сайтов освещающих данную идею. Или просто ищя в сети, какую либо информацию я находил интересные сайты посвященные таким сферам о, которых я даже и не подозревал.

Адрес в Интернете и что такое домен?

Сразу напрашивается вопрос - если в сети так много сайтов как мой сайт найдут те пользователи для которых я его создавал. Ответ на этот вопрос прост, так же как наши дома и квартиры имею адрес, улицу, номер дома, так и сайты имею свои адреса. Например www.mayfirma.ru - это сайт вашей фирмы. Это имя называется доменом второго уровня, то есть RU это домен первого уровня а вот MAYFIRMA - это домен второго уровня. Доменное имя может быть и третьего уровня, к примеру mayfirma.narod.ru. В этой ситуации MAYFIRMA - это уже доменное имя третьего уровня. Получить доменное имя третьего уровня в интернет можно бесплатно, а вот имя второго уровня стоит денег. Доменные имена выдаются в соответствии со строгими правилами. В конце имени, после последней точки, в них содержится так называемое имя домена верхнего уровня. В большинстве случаев это двухбуквенный код страны, которой принадлежит данный ресурс. Например, окончание .ru означает Россию, .uа — Украину, .de — Германию, .fr — Францию и т. д. Кроме того, доменом верхнего уровня может являться также трехбуквенный код, означающий организационную принадлежность ресурса. Например, .com — коммерческая организация, .gov — правительственная, .mil — военная и т. п.

Что такое Хостинг.

Хостинг - это предоставление места, на которое вы разместите сайт, а впоследствии сопоставите свое доменное имя месту где располагаются ваши странички. На самом деле если у Вас компьютер постоянно подключен к интернету то можно разместить странички и на своем компьютере, для этого нужно установить WEB - сервер, сделать определенные настройки, но это очень сложно для неопятного пользователя. Обычно пользуются сторонними серверами для размещения своего сайта, они специально настроены, имею хорошую защиту от вирусов и хакеров, к ним подключены скоростные каналы интернет. Хостинг бывает платный и бесплатный. Естественно платный работает намного лучше и без определенных ограничений. На платном хостинге обычно размещают серьезные сайты. На бесплатном хостинге есть свои ограничения, такие как размещение рекламы на вашем сайте, скорость бывает не важной, то есть пользователи которые пожелали обратится к вашему сайту будут дольше загружать странички чем на платном. К бесплатному хостингу обычно в придачу идет и доменное имя третьего уровня. Получив место на сервере, можно загрузить туда все файлы своей странички. Для этого удобнее всего воспользоваться так называемым FTP- соединением. При этом процесс загрузки файлов на сервер визуально мало отличается от привычного процесса копирования файлов. Например, в программе WS_FTP на левой панели видны файлы, расположенные на своем компьютере, а на правой — файлы, расположенные на удаленном сервере. Для загрузки файлов на сервер необходимо их выделить и нажать кнопку Copy (Копировать).

Какие бываю сайты.

Домашняя Страница
Самый первый шаг в создании Вашего веб сайта - это размещение в сети интернет страницы с названием Вашей компании, очень краткой информацией о ней и контактов. Первый шаг - он самый важный, может быть Вы уже давно собирались пойти на создание сайта, но каждый раз находились причины этого не делать.

Сайт-Визитка
Сайт-Визитка - этим термином обычно называют сайт с информацией о компании, с перечнем продуктов и услуг, возможностью скачать прайс-лист, отправить письмо. Сайт-визитка идеально подходит для компаний, которые хотят разместить информацию о себе и своих услугах в интернете, и впервые столкнулись с задачей создания сайта.

Корпоративный Сайт
Информационный ресурс о компании, ее товарах или услугах. Для большей информативности может содержать описание товаров и их стоимость.

Интернет Магазин
Коммерческое приложение, которое обеспечивает мгновенное проведение сделок через Интернет. Интернет-магазин позволяет значительно расширить розничную / оптовую сеть, выйти с новыми продуктами на ранее недоступные рынки.

Интернет Журнал
Информационный ресурс с большим количеством периодически обновляемых статей на одну тематику. Привлекает читателей свежей и интересной информацией, а рекламодателям интересен собственной базой читателей и подписчиков.

Электронный Каталог
Электронный каталог, как в обычной библиотеке, содержит самые различные сведения в систематизированном виде и быстро обеспечивает доступ к нужной информации.

Интранет/Экстранет
Является, по сути, Интернет-копией вашей фирмы. Охватывает все аспекты деятельности: распределение обязанностей и полномочий между сотрудниками, отделами и филиалами, должностные инструкции, ведение документации и хранение информации.

Этапы создания сайта.

1. Определение цели создания сайта
Цели создания сайта могут быть очень разными. Определение цели создания сайта - важный и ответственный момент. От этого решения будут зависеть трудозатраты и, соответственно, финансовые затраты и сроки создания сайта. Целью создания сайта может быть :
Создание персонального сайта.
Реклама организации, товара или услуг.
Поиск новых клиентов, партнеров, получение заказов через сайт.
Перенос всего бизнеса в Интернет (например, создание интернет-магазина).

2. Выбор индивидуального дизайна, стиля сайта
При выборе индивидуального дизайна сайта важным моментом является баланс формы и содержания. Если на сайте много графики и он переливается всеми красками радуги, но он содержит мало полезной информации - вряд ли сайт станет популярным у посетителей. Другой крайностью может быть интересное содержание (или, как сейчас часто говорят "контент"), но убогий внешний вид.

3. Разработка структуры или "дерева" сайта
Создание структуры или "дерева" сайта - также важный и ответственный момент создания эффективного сайта. В общем случае сайт разбивается на определенные разделы ("ветки"), которые, в свою очередь, могут состоять из ряда страниц ("листья").

4. Подготовка HTML-структуры сайта и навигации
Это один из определяющих этапов создания сайта. Действительно, чего будут стоить все Ваши усилия по определению цели создания сайта, выбору дизайна и разработке структуры сайта, если Вы не сможете все воплотить в виде, понятном браузеру ? На этом этапе создается HTML-структура и продумывается навигация по страницам сайта.

5. Наполнение сайта информацией
В зависимости от объема информации, предполагаемому к размещению на сайте, это может быть одним из самых длительных этапов создания сайта.

6. Тестирование готового сайта
Тестирование готового сайта является необходимым этапом создания любого сайта. При этом проверяется отсутствие грамматических, стилистических ошибок, правильная работа всех гиперссылок.

7. Выбор места размещения сайта в Интернете (хостинг) и регистрация его доменного имени
Необходимо отметить, что размещение Вашего сайта в Интернет и регистрация его доменного имени, наряду собственно с созданием сайта, потребуют определенных затрат. Ежегодно эти затраты могут составлять 10-20 % от первоначальной стоимости создания сайта. Для размещения Вашего сайта в Интернете и регистрации его имени можно выбрать и совершенно бесплатный вариант, который предлагают целый ряд интернет-порталов. Однако в этом случае будьте готовы к различного рода ограничениям (в частности по размеру Вашего сайта) и неожиданностям (например, удаление Вашего сайта как не соответствующего каким-либо требованиям).

8. Продвижение или "раскрутка" сайта
Мероприятия по продвижению Вашего сайта служат делу повышения его популярности (и, соответственно отдачи от Вашего сайта) и могут включать в себя регистрацию в поисковых машинах, участие в службах обмена баннерами, организацию почтовых рассылок и т. д.

9. Обновление сайта
Своевременное обновление информации на Вашем сайте имеет большое значение для удержания аудитории Вашего сайта и привлечения новых и новых посетителей.

Если вы "Хотите всего и сразу" или как заказать сайт.

Если Вы чувствуете силы в себе и сами желаете сделать сайт то я могу желать Вам только успеха и удачи, надеюсь все, что было написано выше Вам поможет разобраться и вы создадите полноценное представительство в Интернет.

Если Вы не желаете или у Вас нет времени разбираться с тонкостями веб технологий, но у Вас есть потребность и желание создать сайт, то я могу Вам в этом помочь. Напишите мне вот по этому адресу.


Спонсоры:

Адрес спонсора
Описание
knigman.net
Система построена таким образом, что первые 5 участников нового дня получают по 0.10 WMR на свой кошелек, все последующие получают по 0.01 WMR. Количество участников - неограниченное. Запрещается получать бонусы одному и тому же человеку несколько раз в день. Такие лица будут отслеживаться и их WM ID будет занесен в черный список.
На WM ID участника, при выдаче бонуса отсылается небольшое рекламное сообщение. Сообщение отсылается только один раз за каждый бонус. Т.е. если вы получили один бонус, то вам прийдет только одно рекламное сообщение. Мы не занимаемся рассылкой спама. Если вы не хотите получать рекламное сообщение, то не получайте бонусы.
На главную страницу: rublei.net
На страницу регистрации: rublei.net
Зачем мы вам ?

У Вас есть сайт, но Вы не знаете как привлечь к себе посетителей? Тогда наш сервис это то, что Вам нужно! При помощи нашего сервиса вы сможете выплачивать бонусы свом посетителям.

Что нужно сделать ?

Все что вам надо сделать это зарегистрироваться , пополнить счет при помощи платежной системы WebMoney , добавить сайт и, получив html-код ссылки, вставить его на свой ресурс.

Все остальное наша проблема :)

Какие требования к хостингу ?

Да никаких! Вам нужна только поддержка HTML :) Все это будет работать даже на бесплатном хостинге!!!

Реферальская программа!

У нас действует реферальская программа! Если человек, зарегистрировавшийся по вашей ссылке, пополнит свой счет, то Вы получите 50% от суммы идущей администрации на свой баланс!

Код ссылки вы сможете получить после регистрации!
Зачем платить за раскрутку своего сайта?! Пусть платят другие!
wmcheck.ru
Бесплатная лотерея Бонус WMR ежедневный розыгрыш от 0.2 до 100 WMR.
zawm.biz
Наша бесплатная лотерея "Удача" является беспроигрышной. Минимальный выигрыш в лотерею составляет 0.02 WMR, максимальный 50.00 WMR.

wmbingo.com
Бесплатно.WMR Каждый первый понедельник месяца, мы выплачиваем 3-ым самым активным игрокам по сбору нашего бонуса, сумму, в размере 10WMR(0.32WMZ)! На текущий момент лидируют:
wmx.ru

В этой акции мы платим Вам за посещение нашего сайта. Нажмите сюда, в появившейся форме введите свой WMI, № R-кошелька и получите заслуженный приз :)

Получить приз c одного WMI можно только 1 раз в день! Причём, если Вы собираете данный бонус с нескольких WMI, то обязательно следите за тем, чтобы его получение происходило с разных IP. Нарушителям этого правила будет отказано в выплате приза. (Новый день на сайте начинается с 00:00:00 по московскому времени).

wmz.net.ru
Хотите проверить Вашу удачу? Тогда Вам именно сюда. В последнее время Сети появляется большое количество разнообразных сайтов азартных игр, которые построены по принципу - " Забери больше - отдай меньше "! На них Вам никогда не удастся проверить - удачливый Вы человек или нет. Где же можно это сделать? Ответ прост - именно здесь. Мы не утверждаем, что только у нас самые честные игры (Мы знаем еще несколько сайтов, которые могут гарантировать честность исхода игры), но Мы стараемся, чтобы пользователи доверяли нам. На сайте у нас вы найдёте большое количество игр как на деньги, так и на интерес (в основном это Flash-игры). Своим посетителям Мы предлагаем получить бонус за посещение в размере 0,02WMR . Да эта сумма не так уж и велика, но среди посетителей, получающих бонусы, проводится розыгрыш - 100WMR ! Поучаствуйте - может Вам повезет! Также на нашем сайте Вы можете зайти и поболтать с другими игроками в чате, оставить сообщение в гостевой книге! Примите участие в нашей Партнерской программе и Вы сможете получать WMZ не затратив при этом ни одной копейки!!! Самое главное - возможность вложить свои деньги в развитие нашего сайта под проценты. Ставки Вы сможете найти в разделе "Инвестиции". В любом случае УДАЧИ!
wmcheck.ru

Сервис голосований Voting .wmcheck.ru - предназначен для создания и проведения голосований, опросов, рейтингов пользователей системы WebMoney Transfer .

Голосование осуществляется через процедуру WM идентификации, этим достигается достоверность результатов голосования и предотвращение массовой накрутки результатов.

Любой пользователь системы WebMoney Transfer, может создать собственный рейтинг, опрос или голосование по интересующей его теме.

Сервис голосований - всего 2 шага к новым возможностям :

  • Целевая аудитория пользователи WebMoney Transfer;
  • Быстрота создания голосования;
  • Закрытое голосование для избранных WM-пользователей;
  • Защита от массовой накрутки результатов голосования;
  • Бонус за голосоание в размере 0.03 WMR один раз в сутки;
  • Еженедельный розыгрыш приза среди организаторов голосований.

wm-loto.net

Бесплатно . Вы хотите получить 100 WMR просто так? Тогда наша новая игра это то что вам нужно, она абсолютно бесплатна ! Вы можете поучаствовать в ней прямо сейчас. В этой игре каждый 2-ой билет получает выигрыш равный 0,1 WMR. Внимание в этой лотерее КАЖДЫЙ сотый купленный билет получает премию на WMR-кошелек владельца в размере !(100) рублей. Проверьте и убедитесь в этом сами. :)

webfortuna.ru
Хотите испытать удачу на нашем сайте, но не хотите рисковать своими деньгами? Hе беда! Введите номер своего R -кошелька и незамедлительно получите от нас бонус: денежный перевод от 0,05 до 100 WMR!!! Так как данная услуга пользуется большой популярностью, бонус временно может не выдаваться. Просто подождите немного и попробуйте вновь. Hикаких ограничений, делать это Вы можете сколько угодно раз!


Поиск цифровых товаров

Поиск: например, мтс или безопасн*

PIN-коды карт экспресс-оплаты МТС, БИЛАЙН, МСС, СОНЕТ, МЕГАФОН, РОЛ, МТУ, Зебра-Телеком, INTERCALL, Матрикс телеком, COMBELLGA, ... | Электронные книги Безопасность, Бизнес и экономика, Компьютеры и интернет, Искусство и культура, Наука и образование, Медицина, ...
Цифровые товары Банерные показы, Документы, ICQ UIN, Доступ к платным ресурсам, Системы активной рекламы, Базы данных, Дизайн, Домены, Заработок в Интернет, ... | Программное обеспечение Бухгалтерия, делопроизводство, Игры, Интернет, Мультимедиа и графика, Рабочий стол, Редакторы, Утилиты, ...


Shareware Russian FAQ

Version: 0.71 from 17.06.1999

FAQ (Frequently Asked Questions) или по русски ЧаВо (Часто Задаваемые Вопpосы) о написании, продаже, распространении и рекламировании условно-бесплатных программных продуктов (Shareware Soft).
Написан на основе архивов списка рассылки (mail list) по данной тематике - Shareware Russian (сокращение SWRUS). Составление - (p) Александр Лысковский < chip@alawar.com >

Содержание:

1. Вступление
1.1 Что такое SWRUS FAQ?
1.2 А кто его написал?
1.3 Где можно найти этот FAQ?
1.4 А кроме этого FAQ что мне еще почитать про SWRUS?
1.5 А дальше этот текст будет расширяться?
2. Разработка и написание программ
2.1 Что вообще такое Shareware?
2.2 А на какую тему мне программу писать?
2.3 Объем предполагаемого рынка.
2.4 Конкуренты.
2.5 Как защитить программу?
2.6 Какие использовать инсталляторы?
2.7 Стоит ли делать программу не только под Win95/98/NT?
2.8 Тестирование.
2.9 Нужно ли делать красивый интерфейс?
3. Процесс получения денег за свой труд
3.1 Сколько должна стоить Shareware программа?
3.2 Какого выбрать регистратора?
3.3 А сколько их вообще надо?
3.4 Как я получу свои деньги?
3.5 Какой выбрать банк в Росии?
3.6 Проблемы с "левыми покупками".
3.7 Как вообще к этому бизнесу налоговая инспекция относится?
3.8 А в Росии мои программы купят?
3.9 А можно ли заработать деньги FreeWare программой?
4. Реклама собственного продукта
4.1 Нужен ли собственный сайт по этой программе?
4.2 А где мне его размещать (хостить)?
4.3 Обязательно ли делать домен .com?
4.4 А на скольких языках должен быть сайт?
4.5 А дизайн там нужен?
4.6 Как мне свой сайт на поисковых системах зарегистрировать?
4.7 И что все про него сразу узнают?
4.8 Про банеры.
4.9 Про кнопки.
4.10 Про сайты со списками Shareware программ.
4.11 Какие есть списки рассылки, где мою программу упомянуть могут?
4.12 А как лучше себя называть - фирмой или конкретным разработчиком?
5. Благодарности
5.1 Авторы ответов. Они же "видные российские шареварщики"
5.2 При написании самого SWRUS FAQ очень помогли

Вступление:

1.1 Что такое SWRUS FAQ?

SWRUS FAQ - это Frequently Asked Questions (Часто Задаваемые Вопpосы) о написании, продаже, распространении и рекламировании условно-бесплатных программных продуктов (Shareware Soft).
Написан на основе архивов списка рассылки (Internet Mail List) по данной тематике - Russian Shareware Authors (сокращение SWRUS). Официальная страничка этой рассылки - http://www.softshape.com/swrus . Модератором конференции является Андрей Черезов , со-модератором Юрий Герасимов .
Данный FAQ содержит большинство ответов на вопросы, возникающие у российского разработчика, который захотел выпустить свою программу на Shareware рынок.
Если вы не обнаружили ответа на интересующий вас вопрос в этом FAQ'е, то задайте мне его через E-mail или прямо в конференции SWRUS (для этого они и создана), и если он окажется интересным, то соответствующий раздел будет добавлен в поздние версии данного FAQ'а.

1.2 А кто его написал?

Набил его Александр Лысковский chip@alawar.com .
А писали его помаленьку (в течении полутора лет) все участники конференции SWRUS, то есть одни из них задавали вопросы, а другие на них отвечали. Отвечали в основном люди из списка который представлен в разделе 5.1 Авторы ответов. Они же "видные российские шареварщики" .

1.3 Где можно найти этот FAQ?
  1. На официальной страничке SWRUS - http://www.softshape.com/swrus/faq_swrus.html
  2. На сервере Alawar Entertainemnt - http://www.alawar.com/faq_swrus/faq_swrus.html
  3. На странице Владимира Кулёмина - http://www.PIMplus.com/misc/swrus/faq_swrus.html
  4. На странице Андрея Черезова - http://www.developer.org.ru/swrus/
1.4 А кроме этого FAQ что мне еще почитать про SWRUS?

По адресу http://www.softshape.com/download/digest.zip лежит дайжест всей переписки SWRUS более чем год его существования. (~500 Kb). Составил и обновляет его Юрий Герасимов < jury@softshape.com >, за что ему большое человеческое спасибо от всех нас.
Дайжест, это как вы понимаете, только наиболее ценные и интересные письма, а если вы хотите поискать что-то во всем архиве конференции SWRUS, то вам сюда:

  • Архив с января 1999 по сегодняшний день (Ведется сервером onelist.com, доступен только для подписчиков)
  • Архив c сентября 1998 по январь 1999
  • Архив до сентября 1998
1.5 А дальше этот текст будет расширяться?

Обязательно!
Обратите внимание на версию этого документа, которая видна сразу же под заголовком.
И вообще, этот рынок развивается очень быстро и меняется тоже быстро - еще 3-4 года назад никто воспринимал Shareware программы как что-то серьезное, еще полтора года назад в Росии было так мало людей, пишущих Shareware, что их можно было пересчитать загибая пальцы на одной руке - и как большой палец там был Евгений Рошал :)

Разработка и написание программ

2.1 Что вообще такое Shareware?

Shareware - это одновременно тип программного обеспечения (ПО) и способ распространения этого ПО. Автор shareware выдает пользователям программного обеспечения лицензию для оценки ПО в течение определенного промежутка времени, обычно в течение 30 дней.
После периода оценки, если пользователь желает продолжить использовать ПО он должен зарегистрироваться, оплатив автору регистрационный взнос.
Основным девизом shareware является "try-before-you-buy (попробуй, прежде чем покупать). Если по истечении периода оценки пользователь не зарегистрирует программное обеспечение для дальнейшего использования, то предполагается, что он прекратит использование ПО и сотрет все файлы.

Shareware программа (даже незарегистрированная), в "идеальном варианте", не должна иметь каких-либо ограничений по сроку работоспособности, по фукциональности или иметь какие-либо другие ограничения. Но в реальной жизни обычно в SW-программу включают некоторые свойства, стимулирующие пользователя зарегистрировать используемое ПО:
- ограничение срока действия ознакомительной версии;
- ограниченная функциональность ознакомительной версии;
- сообщения с напоминанием о необходимости зарегистрировать ПО;
- работоспособность только в среде компилятора (IDE);
- другие способы стимулирования;

Shareware, как метод дистрибуции, является разрешением автора в соответствии c публичной лицензией копировать и передавать ознакомительную версию другим пользователям для оценки. Методы распространения: публикация в сети, группах новостей, на всевозможных FTP, Web-сайтах, BBS; выпуск сборников shareware на CD-ROM и т.д.

Метод shareware работает в значительной степени на факторе честности в людях. Он полагается главным образом на совесть пользователя, чтобы тот совершил честный поступок и зарегистрировал ПО. Успех автора shareware таким образом, зависит не только от качества и полноценности его программы, но и от моральных качеств людей, использующих это ПО.

2.2 А на какую тему мне программу писать?

Существует такое мнение, что продать можно любой продукт :) , лишь бы он был качественно сделан.
Для Shareware подходит почти любая программа, особенно если функции, которые она выполняет, не поставляются заинтересованным пользователям вместе с MS Windows, MS Office и MSIE. Существует огромное количество незанятых ниш в программном обеспечении - их не занимают крупные компании потому что: еще не успели, не заинтересованы в том количестве пользователей, которое этот продукт даст, просто по тому что считают продукты такого рода "несерьезными" и по множеству других причин.
Посмотрите так же повнимательней, что теперь "модно". Помните бум, когда все просто тащились с технологии MP3? В этот время любая программа на эту тематику стала бы популярной. Ну и конечно непереходящий интерес к компьютерным играм и "красивеньким" компонентам и программным библиотекам.
Можно просто работать на ценовом демпинге. Как вариант только: предположим, имеется некий популярный коммерческий продукт, стоимостью $300. Предположим опять же, что ты можешь сделать подобный продукт. Выбрось его на рынок в качестве shareware за $50 и успех тебе гарантирован.

2.3 Объем предполагаемого рынка.

-

2.4 Конкуренты.

-

2.5 Как защитить программу?

По поводу защиты хочется сказать вот что:
1) Абсолютной защиты нет. Если кому-то очень надо будет, все равно вскроют.
2) Стоимость вскрытия защиты должна быть выше стоимости продукта.
3) Самая лучшая защита - частый выпуск новых версий.
4) Перебор с защитой программы ведет к потере потенциального клиента.
Иллюстрацией служит классический анекдот:
"... - неуловимый Джо поскакал,
- а почему неуловимый?
- а кому он НАФИГ нужен?..."
То есть лучше быть известным, чем защищенным, и никому не нужным.
На самом деле следует держаться некого компромисса.

Но если уж очень хочется защититься или ситуация обязывает (бывает и такое), то сделать нужно вот что:
В первую очередь прочитать материалы в Интернете - их более чем достаточно.
download.ru - В Разделе ресурсов есть подборка ссылок. Особо советуются материалы сайта http://www.fravia.org/ и статья Владимира Каталова в Компьютерре - ссылка есть там же.
По опыту, хорошо действуют следующие приемы:

  • Шифрование части исполняемого кода алгоритмом типа blowfish, DES.
  • Шифрование используемых ключей либо RSA, либо хэш-функцией типа MD5. Ключи никогда не должны появляться в программе в открытом виде, только в зашифрованном, причем в одностороннем порядке, как это делает хэш-функция.
  • Отказ от генерации регистрационных ключей по имени пользователя, использование заранее зашитого в программу списка случайно сгенерированных ключей.
  • Размазывание защиты по всему тексту программы.
  • Секундная задержка после ввода рег. ключа пользователем (позволяет избежать тупого перебора ключей).
  • Применяйте хотя бы простейшее шифрование выдаваемых строк, содержащих слова "Register" и т.п.
  • Если вы пишите на Java или библиотеку (компонент) и часть ваших текстов будет видна, используйте "левые" имена переменных и процедур, а не "CheckRegister", к примеру.
2.6 Какие использовать инсталяторы?

Популярные инсталляторы:

MindVision's Installer VISE
Мощнейший профессиональный инсталлятор, используется даже крупными корпорациями (Netscape, Adobe, Claris, Symantec, Microsoft, Kodak...). Стоимость - $695 за первый год и $295 за последующие обновления. Однако для авторов freeware/shareware он бесплатный (правда, выдает соответствующий экран при старте инсталляции, что многих раздражает).

WISE
Славу себе он завоевал самым маленьким (среди инсталляторов-"монстров", конечно) размером получающегося дистрибутива, при этом его возможности не уступают ни InstallShield, ни VISE. Как и VISE, он позволяет вызывать любые функции из DLL и WinAPI. Он имеет свой богатый скриптовый язык, но знать его необязательно - дистрибутив можно сделать в считанные минуты при помощи Installation Expert Wizard. Стоимость - $195.

InstallShield Professional/Express
Этот продукт владеет огромной долей рынка - по информации самой компании, 90 из Top100 программных компаний используют InstallShield. Это старейший продукт, ровесник самой Windows, и за время ее существования стал стандартом де-факто. Он действительно обладает всеми необходимыми возможностями для создания сколь угодно сложных сценариев установки.

Однако это не значит, что для авторов shareware он будет лучшим выбором. Во-первых, стоимость Professional-версии составляет $695, хотя с Delphi и Visual C++ поставляются облегченные бесплатные варианты Express. Во-вторых, размер дистрибутива превосходит все остальные инсталляторы, что только создает лишние трудности при распространении программы через Интернет. И главное, его конкуренты обладают не меньшими возможностями, так что нам есть из чего выбирать.

InstallShield создал себе репутацию монстра, и я бы рекомендовал его использовать для инсталляции не менее монструозных корпоративных продуктов (мегабайт так на 40-50).

INF / IExpress
Не многие знают, что у Microsoft есть свой продукт для инсталляции программ. Вернее, две его половинки. Первая - это inf-файлы, широко используемые в Windows 95/NT для установки драйверов и программ. Возможности языка INF-файлов позволяют делать все, что только можно пожелать - копировать файлы, создавать ярлыки, настраивать различные параметры системы, устанавливать драйвера, шрифты, принтеры и т.д. Язык INF-файлов крайне сложен и, что самое печальное, практически недокументирован. Есть один-единственный shareware-продукт для облегчения разработки INF-файлов - программа INF-Tool by Richard Fellner стоимостью $29.

Другая половина, необходимая для создания полноценной инсталляции - это программа Microsoft IExpress. Она входит в состав бесплатного пакета Internet Explorer Administration Kit , предназначенного для установки Internet Explorer провайдером или администратором сети, но может использоваться и отдельно от него. IExpress создает самораспаковывающийся exe-архив, содержащий все файлы дистрибутива вместе с INF-файлом, который будет запускаться после распаковки архива и собственно заниматься процессом инсталляции. Уникальное свойство IExpress - самое сильное сжатие, заметно лучше, чем у известных архиваторов ZIP или RAR, поэтому его можно рекомендовать даже просто для создания архивов.

InnoSetup
Достаточно крут, доступен на уровне исходного кода, имеет несколько графических оболочек на выбор, при этом Freeware, самораспаковывающийся exe относительно мал, много фичеров и т.п. Для небольшой программы, не требуемой распространения такого монстра как BDE - одно из идеальных решений.

GkSetup
Просто неплохой бесплатный инсталлятор, простой и понятный. Интерфейс инсталляции максимально приближен к стандарту - InstallShield. Использование его вместе с IExpress позволяет достичь минимально возможного размера дистрибутива (надо перед сжатием IExpress'ом распаковать файл setup.da_ командой expand setup.da_ setup.dat и затем переименовать dat в da_).

CreateInstall
Простой, легкий в освоении и компактный инсталлятор. Может удовлетворить все основные потребности при создании инсталляций. Довесок к вашим упакованным файлам будет составлять всего 40KB. В отличии от других инсталляторов - это российская разработка и для российских авторов и компаний он стоит 150 руб, которые можно оплатить денежным переводом.

Правила хорошего тона при подготовке инсталляции:

Соблюдать их необязательно, но весьма полезно. Во-первых, вы облегчите жизнь пользователя, во-вторых, ваша программа приобретет более профессиональный вид, и наконец, у вас повысятся шансы на получение хороших отзывов от обозревателей ZDNet, TuCows и других сайтов.
  1. Многие авторы даже пользуясь инсталлятором, который упаковывает программу в один самораспаковывающийся exe-файл, дополнительно сжимают его архиватором PKZIP или WinZIP и распространяют именно zip-архив. Сайт ZDNet, например, хотя и принимает exe-файлы, перепаковывает их в zip. Не используйте и другие архиваторы, пусть даже они сжимают лучше - дело не в самом сжатии. ZIP - стандарт де-факто на shareware-архивах, а других архиваторов пользователь может и не иметь.
  2. Если вы делаете zip-архив, то всегда включайте в него файл readme, который должен содержать подробную информацию о программе. Он должен быть доступен пользователю еще до начала инсталляции (понимаете теперь, зачем требовался zip ?).
  3. Нормальный инсталлятор должен включать возможность автоматического удаления программы с диска. Стандартный способ сделать это - через пункт "Установка и удаление программ" в Панели управления Windows. Всегда используйте эту возможность ! Программа без деинсталлятора не имеет шансов заработать вожделенные 5 звездочек на ZDNet, и, главное, создает массу лишних проблем своим пользователям.
2.7 Стоит ли делать программу не только под Win95/98/NT?

Стоит. Например под OS/2.
Десятки миллионов инсталляций в мире, особенно много в Европе (в одной только Германии более 10 млн.). Продолжает развиваться, как сама сисема, так и библиотеки различные под нее (уже существует аналог DirectX и свой OpenGL). Существует и свои инсталляторы и все другие необходимыее шареварщику для работы примочки.
Кстати - перекомпилить программу из виндов в OS/2 не так уж и сложно, есть куча кросс-платформенных компиляторов - Visual Age C++, Watcom C++, Sibyl (аналог Delphi), Virtual pascal/2 (один из быстрейших компилеров в мире, совместим c Borland Pascal и Delphi, создает приложения под DOS, WIN, OS/2), не говоря уже о фриварных.
Само собой, пользователей OS/2 не так много, как в виндах, но зато и рынку shareware там есть куда расти! Hет такой бешеной конкуренции. Более того - многих всем известных программ под нее просто нет! Каков простор для деятельности!! :)
Да и с маркетингом можно сильно не заморачиваться - достаточно выложить софтину на известнейший в своем роде http://www.bmtmicro.com/ - лучшей рекламы трудно придумать.
Итого: на мой взгляд - это еще один реальный вариант, куда шароварщику стоит обратить взор для увеличения продаж. Из распространенных операционок остается еще Mac OS, но для нее надо покупать еще один комп, притом весьма недешевый. Ну и набирающий помаленьку сиду BeOS, но туда стоит что-то писать только паралельнос другими платформами.
Намного отдельно стоит разработка Shareware программ под WindowsSE. Писать естественно можно на нормальном PC :). Сейчас в связи с бурным развитеем Palm'овых компьютеров, эта платформа имеет шанс стать такой же полноправной как и ее "старший брат". Пользователи этой ОС неплохо покупают игры, записные книжки, малюсенькеи почтовые клиентвы и так далее, в общем если у вас есть возможность отлаживатся, то стоит попробовать...

2.8 Тестирование.

Есть несколько тестерских тусовок в Сети - то есть люди специально как-то организуются, что бы тестировать новые продукты. Туда можно засабмитить собственную программу и получить отклики людей, которые ее ставили и смотрели, что в других ситуациях иногда бывает сложно. Итак адреса:
- http://www.betanews.com/
- http://www.betabites.com/
- http://www.betabeta.com/
- http://www.betazine.com/
- http://www.betabase.com/
- betatester.tin.it
Особо рекомендуется http://www.betanews.com/ как самый популярный. Известны случаи, когда попадание программы на первую страницу этого сайта увеличивало (пусть всего на несколько дней) число регистраций в 3-5 раз.

2.9 Нужно ли делать красивый интефейс?

Обязательно! Но не столько красивый, сколько удобный и красивый .
Многие даже считают, что интерфейс - это основная составляющая популярности программы. Особенно это относится к программам, которые ваш пользователь будет видеть на экране каждый день (а то и весь день), то есть часики, мэйлеры, файловые оболочки и так далее.
Помочь в создании "правильного" интерфейса вам могут кое какие статьи:
- http://www.useit.org/ (ENG)
- "Task-Centered User Interface Design" (ENG) - скачать можно с gera.irk.ru/freeware.htm
- www.ibm.com/ibm/hci/guidelines/design/ui_design.html (ENG)
- http://www.humanfactors.com/ (ENG)
- info.med.yale.edu/caim/manual/contents.html (ENG)
- msdn.microsoft.com/voices/news/human8_2.asp (ENG)

Статьи на русском языке можно найти в разделе Обзоры на сервере http://www.download.ru/

Процесс получения денег за свой труд

3.1 Сколько должна стоить Shareware программа?

Слишком высокая цена - это плохо, понятно почему.
Слишком низкая - тоже. Буржуи любят сравнивать софт и на основе цен. Низкая цена обычно означает, что он некачественный. Поэтому лучше всего взять ряд конкурентов с похожим уровнем и среди их цен выбрать что-то что ближе к самой низкой цене.
Есть также какая-то сумма которую буржуи готовы выложить не задумываясь из карманных денег, на развлечения скажем так - на игры, скринсейверы, проигрыватели, часики или просто за програму, которая им например понравилась интерфейсом. Это сумма от $10 до $20. Больше программы вышеперечисленных типов стоить наверное не должны, если конечно не обладают какой-нибудь особенной ценностью.

3.2 Какого выбрать регистратора?

Немного о том что вообще такое регистратор.
"Регистратором" называют контору, которая за вас получает деньги от покупателей вашей программы, причем множеством различных способов - в основном, конечно, кредитными карточками, а также почтовыми, банковскими переводами, чеками и даже таким экзотическим способом, как toll-free телефон. Ваши деньги скапливаются у регистратора и уже сами с ним договариваетесь, каким образом вы их получаете - способов тоже множество. Регистрацию покупателей, то есть высылку им регистрационного кода, осуществляет либо сам регистратор, на основе присланного вами генератора ключа, либо вы, после того как регистратор передает вам необходимую информацию о покупателе - имя, e-mail и так далее.

Давайте сначала их перечислим (в квадратных скобках дано более распространенное название):

Название | Условия оплаты
Register Now! [RegNow] http://www.regnow.com/ | 20%, но не менее $2
Kagi http://www.kagi.com/ | 3.5%, но не менее $1
Share It! http://www.shareit.com/ | $2.95+4% от общей суммы. При больших объемах - скидки.
Grey Matter http://www.greymatter.co.uk/ | -
Northstar Solutions http://nstarsolutions.com/ | $3-5 за каждый заказ +5% от общей суммы
Public Software Library [PsL] http://www.pslweb.com/ | $5+4% от суммы заказа
RegNet http://www.swregnet.com/ | $5
RegSoft http://www.regsoft.com/ | При цене программы до $30 - $3, если больше, то 10%
SetSystems http://www.setsystems.com/ | 20%, но не менее $2
Qwerks http://www.qwerks.com/ | 15%
Virtual Software Store [VSS] http://www.virtualsoftware.com/ | 25%, но не менее $5, плюс начальный взнос $69
Digital River http://www.digitalriver.com/ | 20%, плюс начальный взнос $500 (можно сторговаться и без него)
BuyDirect http://www.buydirect.com/ | цены договорные
SWREG SoftShop http://www.soft-shop.com/ | $5+5%
Yaskifo http://www.yaskifo.com/ | $4+3%

Полезные ссылки, которые понадобятся вам при выборе регистратора:
- http://mini.net/pub/sharegs.html - сравнительный анализ большого числа регистраторов.

Самое главное - ни в коем случае не пытайтесь получить деньги напрямую от покупателей!
Здесь все против вас:
а) по нашем росиийским законам, вы можете получить деньги с Запада непосредственно на ваш банковский счет или переводом только в качестве:
- зарплаты по юридически корректно оформленому контракту занятости;
- благотворительный взнос, докуметально подтвержденный;
- материальная помощь от близких родственников.
б) регистрационные взносы очень мелкие и банковская комиссия может съесть весь взнос!

Критерии выбора регистратора от Александра Каталова:
Лучше всего - искать не где процент чуть поменьше, а где - уровень услуг выше!
Нормальный регистратор должен:

  1. Принимать кредитки не только онлайн, но и по телефону (желательно - 800-му) и по факсу и по е-мэйлу.
  2. Принимать к оплате чеки (хотя бы американских банков) а также дорожные чеки на предъявителя (типа American Express или VISA).
  3. Проводить качественную проверку номеров кредитных карточек (как минимум - не пропускать "кодогенераторы", но лучше всего - иметь систему fraud detection и онлайн-связь с карточными системами.
  4. Не брать штрафы за chargebacks и неподтвержденные платежи.
  5. По твоему желанию - не пропускать платежи с "халявных" почтовых ящиков типа hotmail.com или chat.ru
  6. Присылать тебе чеки или делать перевод на твой счет - по твоему выбору.
  7. Высылать тебе деньги в зависимомти от суммы, или по графику - по твоему выбору.
  8. Отсылать покупателю серийные номера или регистрационные патчи - причем в определенной ТОБОЙ форме.
  9. Уметь высылать покупателю программу на физическом носителе - за счет покупателя, естественно.
  10. Варьировать и автоматически пересчитывать стоимость программы в зависимости от количества покупаемых одним клиентом копий программы, и в соответствии с твоими пожеланиями.
  11. Предоставлять тебе возможность настроить форму для регистрации так, чтобы она вписывалась в дизайн твоего сайта.
  12. Помогать тебе рекламировать твою программу - то есть он должен сам выпускать диски, иметь свой онлайн магазин, или обслуживать при этом крупный и престижный shareware-сайт.
  13. Высылать тебе информацию о каждом покупателе мэйлом, плюс месячный баланс по всем продажам
  14. Предоставлять тебе возможность онлайн-доступа к твоему эккаунту, причем ко всем покупкам и к ПОПЫТКАМ купить (когда платеж не был сделан), с указанием, какие деньги тебе уже были перечислены и когда, и прочее... Причем информация о продажах в этой базе должна сохраняться даже после того, как тебе были переведены деньги - то есть с самого начала твоей работы!

Если регистратор делает меньше половины перечисленного, то это и не регистратор вовсе, а так - merchant service несчастный.

3.3 А сколько их вообще надо?

По соображениям здравого смысла и по опыту работы разных шароварщиков оптимальное число - два. Если больше - пользователь будет выбирать регистратора совсем уж случайным образом, и вы будете иметь проблему со множеством мелких платежей. Двух же лучше иметь как по соображениям надежности (канал упал), так и по сумме услуг, которые они предоставляют (ни один регистратор не может объять необъятное). Например, у одного очень низкий процент или фиксированная цена, и крупные покупки по нескольку штук через такого регистратора проводить будет выгодней, а второй пусть имеет лучше защиту от взлома и фальшивых кредиток - это для единичных покупателей - тут не жалко доплатить за такой сервис и процент может быть побольше.

3.4 Как я получу свои деньги?

Есть два популярных способа - чеком и перечислением на счет. Что лучше, зависит от регистратора и от вашего банка. Перечисление быстрее (до недели), но за него регистратор (точнее, его банк) берет комиссию до $40 (у всех по-разному). Кроме этого, может оказаться критичным, что именно напишет регистратор в графе "Мотив платежа" при перечислении денег. Если там окажется salary или payment - могут быть проблемы с налоговой. Лучше писать support или что-то аналогичное. Чеки избавлены от таких проблем, но идут почтой, и от момента высылки чека регистратором до получения денег в вашем банке может пройти до 2-3 месяцев.

3.5 Какой выбрать банк в Росии?

По поводу нестабильности с коммерческими банками, особенно, в регионах, лучше пожалуй выбрать "полугосударственные" банки, а именно - ВнешТоргБанк и СберБанк . Причем первых их них предпочтительней - и сервис получше и работники повежливей.
Что нужно сделать? Нужно придти в банк и открыть там валютный счет на свое имя. В разных банках это стоит по разному - во ВнешТоргБанке например $5. На этот счет деньги можно переводить и из заграницы, так будто ваш счет и находится там (что и интересует регистраторов). Происходит это потому, что между вашим банком и западным (например американским Bank of New York) существует соответствующее соглашение. По смыслу это будет как бы ваш счет в американском банке, но только получать вы деньги будете в России - там где открыли счет.
Когда счет открыт и все реквизиты вам известны, не забудьте попросить банковского служащего, который вам все это оформлял, написать на бумажке на английском языке все необходимые реквизиты. Транскрипцию вашей фамилии и имени можно взять из загранпаспорта, а если его нет, то опять же попросить банковского служащего написать.
Выглядеть это будет примерно так (пример для Новосибирского ВнешТоргБанка):

Account of Novosibirskvneshtorgbank NO. XXX-XXXX-XXX
with The Bank of New York, New York in favour of
Ivanov Ivan
Account NO. XXXXX
with Novosibirskvneshtorgbank, Novosibirsk, Russia.
1, Lenina str., Novosibirsk, 630007, Russia, SWIFT: XXXXXXXX.
3.6 Проблемы с "левыми покупками".

Достаточно индивидуально у каждого регистратора.
Крутой RegNow регулярно их пропускает, но менее крутым не становится. Они кстати утверждают, что _вручную_ проверяют каждую покупку, что странно если учесть проскакивающих John Smith'ов с улицы Doоm дом 666. Впрочим у них, как и у многих регистраторов, позволяется автору самому поставить флажок - "не доверять этой покупке".
Например, я пользуюсь регсофтом, так вот ни одного фрауда или chargeback не было за более чем год и несколько сотен регистраций регсофт не пропустил. Иногда они даже усердствуют в этом вопросе - был случай, когда итальянка, временно проживающая в Румынии хотела купить, указав все итальянские регалии. В результате поимела проблем, которые, впрочем, закончились для нее благополучно - получила долгожданный ключик.
Когда же я пытался ихнему менеджеру написать, что дескать, побыстрее бы, он ответил, что у них фраудов 0.01% и они этой цифрой страшно гордятся, потому, дескать, дай нам делать свою работу.

3.7 Как вообще к этому бизнесу налоговая инспекция относится?

-

3.8 А в Росии мои программы купят?

В зависимости от того какая программа и сколько стоит :-)
Многие российские авторы для своих соотечественников делают различные поблажки при оплате - скидки, самостоятельный прием денег (чаще всего в рублях и почтовым переводом), некоторые так и вообще делают бесплатную русскую версию.
Но для желающих именно "продавать" есть неплохое предложение от фирмы "АДАСОФТ" - сайт посвященный продажам Shareware за рубли - http://go.kostroma.net/swrub

3.9. А можно ли заработать деньги FreeWare программой?

Можно и даже несколькими способами.
Первый способ - сайт о программе:
Самый простой пример действенности этого способа - это WinAmp <http://www.winamp.com>. Я не понимаю, зачем они сделали его shareware (из просто бесплатного), пусть и nag-free, ведь и так неплохо получалось...
Возьмем в руки калькулятор и снимем показания счетчика на первой странице сайта www.winamp.com - за последний месяц у них около 2.5 млн. посетителей ! Зная среднюю стоимость рекламы у них - $25 / CPM, получаем, что за месяц только баннеры на первой странице сайта приносят им около 60.000 USD. При этом их коллектив весьма небольшой (на сайте перечислено 5 человек).
Конечно, Winamp в первую очередь - просто очень хороший продукт. Однако его бесплатность явно способствовала популярности. Оказывается, на одной популярности тоже можно деньги зарабатывать... Чего и всем желаю :)
Второй способ - баннер внутри программы:
Да-да, именно баннер - такой же, какой вы видите на некоторых страничках в InterNet'е.
То есть за то, что вы в свою программу встраиваете упоминание о какой-то фирме, или сайте, или продукте - вам платят деньги. Или еще бывают библиотеки специальные, которые вы должны будете вставить в свою программу и она будет циклически у каждого пользователя показывать эти банеры - качая их с сети или просто с вашего диска.
Вот несколько контор, которые предлагают такой сервис для ваших FreeWare программ:
1. Aureate Software ???
2. <http://www.hotfreeware.com>
3. <http://www.timesink.com>

Реклама собственного продукта

4.1 Нужен ли собственный сайт по этой программе?

Просто необходим !
Программа все равно где-то в Интернете должна лежать, иначе ее невозможно будет распространять через основные shareware-сайты ( http://www.winfiles.com/ , http://www.download.com/ и многие другие ставят у себя только ссылку на вашу программу и описание, а скачивание происходит все равно с вашего адреса). Лучше, если это будет собственный сайт с описанием функций, дополнительным сервисом и другой полезной информацией. Его можно сделать совершенно бесплатно - или у своего провайдера, или на халявных серверах (смотрите следующий раздел).

4.2 А где мне его размещать (хостить)?

Есть несколько неплохих списков хостеров с обзорами и рейтингами, вот они:
http://www.tophosts.com/ - обладает очень удобным поиском по цене, досупности и прочим опциям.
http://www.ispcheck.com/ - позволяет задавать свои требования и ищет подходящие варианты среди 12,000 хостеров.
http://ghuberty.hypermart.net/listing.htm - список дешевых хостеров c подробными комментариями о каждом.
http://www.hostindex.com/ - утверждают что собрали у себя ссылки на ВСЕХ хостеров.
http://www.hostinvestigator.com/ - имеет поиск, обзоры пользователей и форум для обсуждения вопросов, связанных с хостингом.

Из бесплатных, но неплохих стоит упомянуть о:
http://www.hypermart.net/ - 10Mb с докачкой, неограниченный трафик, скорость хорошая из любой точки мира.
http://www.webjump.com/ - 25Mb с докачкой, неограниченный трафик, но рекламный банер на полстраницы.

4.3 Обязательно ли делать домен .com?

Как только пойдут "серьезные" дела - обязательно!
Сделать это можно через службу Internick < http://www.networksolutions.com/ >. Стоит это 70$ за первые два года и по 35$ в год потом. Кстати, при регистрации платить можно не сразу - в течении 1-2 месяцев, чем вполне можно воспользоваться, что бы успеть продать несколько копий и с этих денег оплатить регистрацию домена. Да и некоторые регистраторы спокойно относятся к просьбам перевести часть денег на счет Internick'а.
Некоторые платные хостеры делают за вас эту регистрацию, там это даже иногда дешевле получается.

4.4 А на скольких языках должен быть сайт?

Первая страница - обязательно на английском.
Если хотите, можете делать страницы на других языках и ссылаться на них с главной. Особенно, если у вас есть версия вашей программы, локализованная для этого языка.

4.5 А дизайн там нужен?

-

4.6 Как мне свой сайт на поисковых системах зарегистрировать?

Существует куча бесплатных сервисов для этого. Один из самых больших по охвату - http://www.thepromoter.com/

О том как надо оптимизировать свой сайт для поисковиков неплохо написанно вот здесь:
- http://searchenginewatch.internet.com/sitemap.html (ENG)

4.7 И что все про него сразу узнают?

Нет - не сразу.
Надо заниматься "раскруткой" сата. Вот несколько учебников по тому как это делать:
- http://www.glasnet.ru/glasweb/rus/sitepromo1.html (RUS)

4.8 Про баннеры.

-

4.9 Про кнопки.

-

4.10 Про сайты со списками Shareware программ.

Существует несколько списков такого рода сайтов:
- Список Александра Самсонова < http://www.aha.ru/~aasamson/archives > (RUS)
- Список Дмитрия < http://www.download.ru/russian/content/resources/shareware.htm > (RUS)
- Ссылки на субмит-страницы < http://www.downloadshareware.com/shareware.html > (ENG)

4.11 Какие есть списки рассылки, где мою программу упомянуть могут?

Многие Shareware архивы имеют собственные списки рассылки ( http://www.download.com/ , http://www.winfiles.com/ , http://www.download.ru/ , http://www.tucows.com/ ), которые получают иногда сотни тысяч человек. Но вы там будете упомянуты, если того захочет редактор соответствующего архива.
Есть так же списки рассылки посвященные например программированию под Delphi, там очень в тему будет смотреться упоминание о вашей Shareware компоненте, или списки новостей мира компьютерного мира, и так далее. Ищите и найдете, в общем...

Есть специализированный и очень популярный в мире список рассылки, посвященный freeware/shareware-программам - http://www.lockergnome.com/ . Не проходите мимо :).

4.12 А как лучше себя называть - фирмой или конкретным разработчиком?

Думаю, что от фирмы (даже если реально она будет состоять из одного человека) в любом случае лучше будет продаваться. Доверия больше. У корпоративных пользователей -- понятно, почему; думаю, что и у индивидуальных тоже. Довольно многие думают, что если программа сделана одним человеком, то он запросто может прекратить ее поддержку, или даже просто не отвечать на письма... В конце концов, заболеть, переехать в другой город и т.д. А фирма (особенно со своим именем домена, соответствующим названию) -- это солидно. В реальности, конечно, все может быть наоборот, но это уже неважно...
Опять же, платежи. Сам подумай, кому ты меньше постремаешься платить кредиткой в онлайне -- Васе Пупкину или фирме "Advanced Research, Inc."? :))) Понятно, что платежи принимает не сам автор, а американский посредник. Но это нам понятно. А не пользователям (во всяком случае, не всем), особенно если дизайн страницы заказа подогнан под homepage автора.
Юридически можно даже никак эту "фирму" не регистрировать - все равно "Джон из Кентукки" не поедет это проверять. Хотя сейчас, чтобы сделать в Росии юридическое лицо и зарегистрировать его название на себя, много денег и времени не надо - 6000 руб. уставной капитал (который можно тут же забрать), 1500 руб. за регистрацию фирмы по месту проживания и около 2000 руб. на регистрацию названия по всем международным правилам. Правда тут уже возникает проблема уплаты этом юридическим лицом налогов, но это уже совсем другая история...
Впрочем, есть пожалуй парочка исключений из этого:
Во-первых, легкие игры и всякие там скрин-сейверы - они очень неплохо смотрятся если их сделал "простой парень" и на страничке этого продукта нет не капли корпоративности и серьезности. А, например, фотография любимой собаки или шутливом рассказ о собственном колледже.
Во-вторых, когда ваше собственное имя может быть известней, чем любое раскрученное название. Пример:
1. Вы не хотите купить Microsoft Puzzle Collection?
2. Вы не хотите купить набор головоломок написаный автором Тетриса, Алексеем Пажитновым?
Ну или второй пример - Евгений Рошаль (который этого никогда не прочтет, к сожалению :) совершенно правильно в своих продуктах везде пишет имя, а не фирму, так как знает что _любую_ программу "от Рошаля" поставят, посмотрят и если смогут - купят, по крайней мере в России.

Благодарности

5.1 Авторы ответов. Они же "видные российские шареварщики".

  • Victor Ishikeev < ivi@rb.ru > ( ??? )
  • Vladimir Katalov < kitten@elcomsoft.com > (Elcom Ltd < http://www.elcomsoft.com/ >)
  • Alexander Katalov < alex@elcomsoft.com > (Elcom Ltd < http://www.elcomsoft.com/ >)
  • Andrey Cherezov < ac@eserv.ru > (EServ < http://www.eserv.ru/ >)
  • Jury Gerasimov < mailto:%20jury@softshape.com > (SoftShape < http://www.softshape.com >)
  • Alexey Krivonogov < mailto:hotocean@sibtel.ru> > (CreateInstall HomePage < http://www.gentee.com/ >)
  • Konstantin Vyatkin < mailto:konstantin@vypress.com> > (VyPRESS Research, Inc. < http://www.vypress.com/ >)
  • Stan Grishin < swrus@reget.com> (ReGet Software < http://www.reget.com/ >)
  • Alex Salamakha < alex@capstralia.com > (Capstan Australia Pty Ltd < http://www.capstralia.com/ >)
  • Alexander Lyskovsky < chip@alawar.com > (Alawar Entertainment < http://www.alawar.com/ >)
5.2 При написании самого SWRUS FAQ очень помогли:

Юрий Герасимов , исправивший все мои грамотические и стилистические ошибки и описки, а так же давший огромное колличество ценных советов и дополнений ( Эта фраза была оставлена как есть. - Ю.Г. : ).